Vmware en Edgy Eft

Uno de los tantos problemas que tuve al actualizar mi Kubuntu Dapper Drake a Edgy Eft fue el Vmware, yo uso el Workstation pero también el player(que es libre), el problema era que me tiraba la siguiente linea:

Unable to build the vmmon module.

y contenia esto en el mensaje de error:

/tmp/vmware-config3/vmmon-only/./include/compat_wait.h:60: error: conflicting types for ‘poll_initwait’ include/linux/poll.h:62: error: previous declaration of ‘poll_initwait’ was here

El problema es que el modulo del vmware no es compatible con el kernel nuevo(el que viene con edgy eft), en estos casos bastaria con un sudo vmware-config.pl para compilarlo de nuevo, pero en este caso no funciona asi, entonces hay que bajar el parche “vmware-any-any-update” lo podes bajar de aca:

http://platan.vc.cvut.cz/ftp/pub/vmware

para mas info sobre este parche: http://www.vmware.com/community/thread.jspa?messageID=76957&tstart=0

basta con bajar el archivo vmware-any-any-updateX.tar.gz (donde X es el nro de version), descomprimirlo y ejecutar el archivo runme.pl, ignora los “warnings” que te va a tirar en pantalla, despues ejecuta

$ vmware-config.pl -d

y va a recompilar el modulo(-d = opciones por defecto), ahi ya esta! tu VMware esta funcionando de nuevo sin problemas!

Obs: Para compilar hace falta los paquetes g++ y gcc, instalalos con la siguiente linea:

$ apt-get install build-essential

y todo solucionado!

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s